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Using Formulas in Spreadsheets
Using formulas provides more value and productivity to your work. Good use of formulas helps to design better
spreadsheets with reduced complexity and increased ease. They help reduce errors and improve troubleshooting.

Formulas and functions
A formula is an expression which calculates the value of a cell. Functions are predefined formulas and are already
available in Excel. Functions are preceded by a letter code that tells Excel what to do with the selected data.

Ways of entering formulas
Always enter a formula into the cell where the result should appear. Formula can be entered in the following ways:

1. Use the Editing option in the Home tab.
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2. Use the Formulas tab.
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3. Enter the formula in Formula bar
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Named cells
You can refer to a single cell or a group of cells using a name rather than by cell reference.

Create a named cell or named cell range:
1. Select the cell or cell range.
2. On the Formulas tab, in the Define Names group, click the Define Name button.
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For example, you might name the
cells A20 to A40 “Expenses.”

Names can be used in formulas to
make lhem usier lo undﬂstand

Q Press F1 for more help.

3. In the New Name dialog box, specify three things:
a. In the Name box, type the range name.
b. In the Scope dropdown, set the name scope (Workbook by default).
c. Inthe Refers to box, check the reference and correct it if needed.
4. Click OK to save the changes and close the dialog box.
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List of Formulas Used In Today’s Class

1. Sum(range)
Adds individual values cell references and ranges
2. Average(range)
Returns average (arithmetic mean) of the values, cell references and range entered.
3. Max(range)
Returns largest of the values, cell references and range entered.
4. Min(range)
Returns smallest of the values, cell references and range entered.
5. Int(number)
Rounds the number down to the nearest integer.
6. Round(number,num_digits)
Round the number to the specified number of digits.
7. Count(range)
Counts the number of cells in a range that contain numbers.
8. CountA(range)
Counts the number of cells in a range that are not empty.
9. Countif(range, criteria)
Counts the number of cells in a range that match the given condition.
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Tasks for Excel Formulas

These tasks use the file Excel_Formula_Tasks.xlsx that was sent to each registrant. Please feel free to open this
file and follow along during the presentation. Follow the steps outlined below to complete each task. Need the
Excel file? Please email rmurray@wnpl.info.

1. Adding or Totaling Data Using AutoSum

e In cell Q2, enter the formula to calculate total of January (J2:P2) using AutoSum in Home tab.

e To do this, click cell Q2, then select “AutoSum” in the Home ribbon. The result will appear in cell
Q2.

2. Replicating the AutoSum Formula

e Replicate the formula in cell Q2 in cells Q3 through Q9.

e To do this, copy the formula in cell Q2 by selecting cell Q2, then click “Copy” on the Home ribbon.

e Select cells Q3 through Q9 with the mouse.

e Select “Paste” on the Home ribbon to complete the process.

e Users may also copy a cell’s contents by selecting the cell, then right-clicking and choosing “Copy.”
Data may be pasted the same way - select the cells to paste data into, then right-click and select
“Paste.”

3. Calculating an Average

e In cell R2, enter the formula to calculate average of January (J2:P2) using Formula tab.

e Click cell R2, then select the Formulas tab at the top of the page.

e From the Formula ribbon, select “More Formulas,” then “Statistical.” The second choice in the
Statistical formulas is “Average” - select Average to begin calculating the average.

e A dialog box will appear - click the [EE/;] “retrieve data” button at the end of the field marked
“Number 1.”

e Select cells J2 through P2. Click the “enter data” button in the minimized dialog box, then click
“OK” to finish the calculation. The answer will appear in cell R2.

4. Replicating the Average Formula

¢ Replicate the formula from the exercise above in cells R3 through R9.

e To do this, copy the formula in cell R2 by selecting cell R2, then click “Copy” on the Home ribbon.

e Select cells R3 through R9 with the mouse. Select “Paste” on the Home ribbon to complete the
process.

e Users may also copy a cell’s contents by selecting the cell, then right-clicking and choosing “Copy.”
Data may be pasted the same way - select the cells to paste data into, then right-click and select
“Paste.”

5. Calculate a Maximum (Highest Value), Using the Home Ribbon Shortcut

e Incell S2, enter the formula to calculate the maximum value in January (J2:P2) by entering the
formula in the cell.

e Click cell S2, then select the drop down arrow next to “AutoSum” in the Home Ribbon. Select “Max”
from the drop-down menu.

e A selection box will appear around the data in cells J2 through R2, but this selection box will need
to be edited to reflect the correct data. Click cell J2, and drag the selection box across the row to
cell P2, then press Enter on the keyboard. The highest value found in cells J2 through P2 will now
appear in cell S2.
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6. Replicating the Maximum Formula

e Replicate the formula in cells S3 through S9.

e To do this, copy the formula in cell S2 by selecting cell S2, then click “Copy” on the Home ribbon.

e Select cells S3 through S9 with the mouse. Select “Paste” on the Home ribbon to complete the
process.

e Users may also copy a cell’s contents by selecting the cell, then right-clicking and choosing “Copy.”
Data may be pasted the same way - select the cells to paste data into, then right-click and select
“Paste.”)

7. Calculate a Minimum (Lowest Value), Using the Formula Bar

e In cell T2, manually enter the formula to calculate minimum in January (J2:P2) by entering the
formula in the formula bar. The formula code for finding the minimum is MIN.

e Click cell T2, and begin the formula with an equal sign [the finished formula should look like this:
=MIN(J2:P2)]. Once the formula is entered, press Enter on the keyboard. The lowest value from
cells J2 through P2 will appear in cell T2.

8. Replicate the Minimum Value:

e Replicate the formula you created above in cells T3 through T9.

e Todo this, copy the formula in cell T2 by selecting cell T2, then click “Copy” on the Home ribbon.
Then, select cells T3 through T9 with the mouse. Select “Paste” on the Home ribbon to complete
the process.

e Users may also copy a cell’s contents by selecting the cell, then right-clicking and choosing “Copy.”
Data may be pasted the same way - select the cells to paste data into, then right-click and select
“Paste.”

9. Find the Integer Value (rounding down to the closest whole number)

e In cell J15, calculate the integer value of cell J14. Cell J14 contains a number with decimals.
Finding the integer value allows us to round the number in this cell DOWN to the closest whole
number with no decimals.

e To do this, click cell J15; then, select the Formulas tab. On the Formulas ribbon, choose the drop
down arrow below “Math & Trig” in the Function Library. Search for the integer command, INT, and
click once.

e A dialog box will appear - click the “retrieve data” button at the end of the field marked
“Number 1.” Select cell J14 with your mouse.

e Click the “enter data” button in the minimized dialog box, then click “OK” to finish the
calculation. The answer will appear in cell J15.

10. Rounding the Value to a Decimal Point

e |n cell J16, calculate the value of cell J14 rounded to 2 decimal places.

e To do this, click cell J16; then, select the Formulas tab. On the Formulas ribbon, choose the drop
down arrow below “Math & Trig” in the Function Library. Search for the Round command, ROUND,
and click once.

e A dialog box will appear, with two fields - click the “retrieve data” button at the end of the field
marked “Number.” Select cell J14 with your mouse. Click the “enter data” button in the
minimized dialog box.

e In the second field, marked “Num_digits,” type the number of decimal places to round to (in this
case, 2). Click “OK” to close the dialog box. The rounded result will appear in cell J16.

ﬁmmmmm“‘ml WARREN-NEWPORT PUBLIC LIBRARY
i ® 224 North O'Plaine Road * Gurnee, IL 60031
T Wn 847-244-5150 * wnpl.info



11. Rounding the Value to the Closest Whole Number

e Incell J17, calculate the value of cell J14 rounded to nearest whole number.

e To do this, click cell J17; then, select the Formulas tab. On the Formulas ribbon, choose the drop
down arrow below “Math & Trig” in the Function Library. Search for the Round command, ROUND,
and click once.

e A dialog box will appear, with two fields; click the @ “retrieve data” button at the end of the field
marked “Number.” Select cell J14 with your mouse. Click the [& “enter data” button in the
minimized dialog box.

¢ In the second field, marked “Num_digits,” type the number of decimal places to round to (in this
case, we want to round to the nearest whole number, so enter “0”). Click “OK” to close the dialog
box. The rounded result will appear in cell J17.

12. Rounding the Value to the Closest Value of 10 (negative decimal)

e In cell J18, calculate the value of cell J14 rounded to nearest ten’s place (or a negative decimal
place).

e To do this, click cell J18; then, select the Formulas tab. On the Formulas ribbon, choose the drop
down arrow below “Math & Trig” in the Function Library. Search for the Round command, ROUND,
and click once.

e A dialog box will appear, with two fields - click the “retrieve data” button at the end of the field
marked “Number.” Select cell J14 with your mouse. Click the “enter data” button in the
minimized dialog box.

e Inthe second field, marked “Num_digits,” type the number of decimal places to round to (in this
case, we want to round to the nearest negative decimal place, or the nearest value of 10, so enter
“-1"). Click “OK” to close the dialog box. The rounded result will appear in cell J18.

13. Naming a Data Range (naming a list of numbers, words, etc.)

e Name the range 015:021 as Values.

e To do this, select the cells 015 through 021 using your mouse (hold down the left mouse button
and drag across all cells in that range); then, select the Formulas tab. On the Formulas ribbon,
locate the “Defined Names” menu, and click the “Define Names” button.

e Adialog box will appear - in the field labeled “Name,” type “Values” and click OK. The selected
fields are now labeled Values.

14. Finding Numeric Values in a Named Range

e In cell 022, calculate how many numeric values are present in the range Values.

e To do this, click cell 022. Then, select the Formulas tab, and click the drop-down arrow next to
“More Functions.” From this list, select “Statistical,” and then click “COUNT” (COUNT is the function
command to count how many numbers are in a set of values).

e A pop-up window will appear. In the first field (Valuel), enter the name for our range of data - type
Values. C

e Click “OK” on the pop-up window. Cell 022 will contain the total number of number values in our
named data range (in this case, the answer is 3 — *1 is not recognized as a number, because it is
preceded by an asterisk).

15. Finding All Alphanumeric Values in a Named Range

e In cell 023, calculate how many alphanumeric values are present in the range Values (letters,
numbers, or common symbols - essentially, how many cells have anything entered into them).

e To do this, click cell 022. Then, select the Formulas tab, and click the drop-down arrow next to
“More Functions.” From this list, select “Statistical,” and then click “COUNTA” (COUNTA is the
function command to count how many cells have entries in a set of values).
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e A pop-up window will appear. In the first field (Valuel), enter the name for our range of data - type
Values. Then, click “OK” on the pop-up window. Cell 022 will contain the total number of
alphanumeric values in our named data range (in this case, the answer is 6 - six cells have some

type of data entered in them).
16. Finding All Cells with a Specific Value

e In cell J25, calculate the number of hourly employees. To do this, click cell J25 (labeled Number of
Hourly Employees). Then, select the Formulas tab, and click the drop-down arrow next to “More
Functions.” From this list, select “Statistical,” and then click “COUNTIF” (COUNTIF is the function
command to count how many cells have entries that meet a specific value in a set of data). A pop-
up window will appear. At the end of the first field (Range), click the 5| “retrieve data” button, and
then select the data in cells B2 through B40. Click the @ “enter data” button on the minimized
drop-down box. In the second field (Criteria), type “Hourly” to locate how many cells contain that
term. Click the “OK” button, and the result will appear in cell J25 (in this case, the answer is 4 -
there are 4 hourly employees, according to this set of data).

17. Finding All Cells with a Value Greater Than a Specific Number: In cell J26, calculate the number of
employees with a salary of more than 50,000. To do this, click cell J26 (labeled “Number of employees
with salary more than 50,000”). Then, select the Formulas tab, and click the drop-down arrow next to
“More Functions.” From this list, select “Statistical,” and then click “COUNTIF” (COUNTIF is the function
command to count how many cells have entries that meet a specific value in a set of data). A pop-up
window will appear. At the end the first field (Range), click the “retrieve data” button, and then select
the data in cells B2 through B40. Click the “enter data” button on the minimized drop-down box. In the
second field (Criteria), type “>50,000” to locate how many cells contain a value greater than 50,000. Click
the “OK” button, and the result will appear in cell J25 (in this case, the answer is 16 - there are 16
employees that make greater than 50,000 per year, according to this set of data).
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